In recent years, Sage has been actively supporting the current perpetual-license version of Timeslips, along with the two most recent versions. Recently, our Timeslips clients began to receive emails from Sage indicating that support for both Timeslips versions 2015 and 2016 will be discontinued as of August 1In our post earlier this week we provided information on this as well as other recent Timeslips developments.

What this means is that even if, for example, your firm just upgraded to version 2016 a year ago, your version will become “obsolete” as of August 1 of this year. Why is this important?

  1. Sage support seems to be following industry trends;
  2. Product add-ons such as additional licenses and the electronic billing interface can be purchased only for supported versions;
  3. Sage Timeslips eCenter works only with supported versions of Timeslips;
  4. Sage will undertake repair of databases for supported versions only;
  5. Firms that have a policy of keeping current on all their software will need to upgrade at least every two years.

If you have not yet upgraded to the Firebird database, you may want to consider doing so before support for older versions is discontinued this summer. We suggest reviewing the system requirements for the new database with your IT consultants to be sure your hardware is up to the task. Our clients using the Firebird database report that it is more resilient and less prone to corruption than the outdated BDE database.

Some of our clients have received communications from Sage that would seem to indicate that the “perpetual license” edition of Timeslips is no longer available. This is not the case. While Sage sales representatives may emphasize the Premium (subscription) edition of Timeslips, you can still purchase the perpetual license (non-subscription) edition from consultants.

The good news?

Our consultants at Crosspointe can help you upgrade to a supported version of Timeslips. Firms may want to consider this, particularly those using eCenter or needing to purchase add-ons in the near future. If your office is replacing workstations with new ones running Windows 10, you’ll want to check with us to be sure your version supports this version of Windows. We continue to support all versions of Timeslips to the extent possible, so we have you covered no matter what.

Crosspointe Consulting Group, LLC can help you get your Timeslips upgrade, install it, and convert your data to Firebird, as well as provide support on outdated versions when required. Also, ask us whether the time is right for your firm to consider a Sage Business Care plan to aid in staying on a supported version. Call us at 877-357-0555 or write to us at info@crosspointecg.com to make sure your firm is using the best version of Timeslips for your needs.